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Simulación de circuitos con PSpice

1. Introducción

CADENCE (Orcad, MicroSim) PSpice es un entorno de análisis y síntesis de circuitos elec-
trónicos que da soporte a las siguientes tareas:
• Captura de esquemáticos
• Simulación a nivel eléctrico
• Simulación lógica y de modo mixto
• Optimización de circuitos
• Edición de placas circuitos impresos o PCBs (“Printed Circuit Board”)
• Representación gráfica de las formas de ondas

Esta herramienta esta basada en PSpice, versión profesional de Spice (Simulation Program
with Integrated Circuit Emphasis, popular simulador eléctrico de la University of California,
Berkeley). A la potencialidad del simulador eléctrico PSpice, se le une la comodidad de manejo
que ofrece la captura de esquemáticos y la entrefase gráfica, así como la disponibilidad de un
gran número de librerías para componentes comerciales en la versión completa de MicroSim
Pspice.

El objetivo de esta práctica es familiarizarse con un entorno profesional de simulación eléc-
trica de circuitos. Dicha actividad comprende tres pasos fundamentales: (a) captura de
esquemáticos y modelos; (b) edición de estimulos, tipos de análisis y simulación; (c) análisis
de los resultados, visualización y medida.

2. Primer Ejemplo: Circuito RC

Consideremos un filtro pasivo RC de primer orden
como el que se muestra en la Fig.1. Analizaremos las
característica de dicho circuito usando el entorno
MicroSim PSpice.

2.1 Introducción del esquemático

La primera tarea consistirá en la captura del
esquemático (CE) del circuito RC. Para ello arrancaremos la utilidad “Schematics” del entorno
“DesignLab Design Manager”. Deberá aparecer un panel en blanco donde “dibujaremos” el
esquemático.

Los componentes del circuito (en este caso fuente de tensión, resistor y condensador) se
encuentran en una de las librerías de componentes de la herramienta. Para acceder a dichas
librerías activaremos Draw->Get New Part... en el menú de CE (o equivalentemente pulsare-
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mos al unísono la teclas Ctrl y G). En el menú resultante se muestran los nombres de todos los
componentes en todas las librerías disponibles (en la versión demo) y una breve reseña de su
función. Si se sabe el nombre de la librería en que se encuentra el componente que se está bus-
cando, se puede seleccionar desplegando el menú Libraries... En cualquier caso, esto no es
necesario pues en la lista que se nos ofrece por defecto están incluidos todos los dispositivos
posibles. Pulsando la opción Advanced, además se muestra el símbolo del elemento que selec-
cionemos picando una vez sobre su nombre.

Seleccionaremos los elementos que forman el circuito. Para ello, con el ratón sobre la ventana
de nombres pulsaremos en el teclado la/s primera/s letras/s del nombre del símbolo que estamos
buscando, con lo cual la lista se deplazará rápidamente hasta el primer símbolo cuyo nombre
comience con estas letras.

En el ejemplo, comenzaremos con la fuente de tensión. Existen varios símbolos para fuente
independiente de tensión en PSpice, dependiendo de sus características (constante, variable en
el tiempo, AC, etc.). Sin embargo, existe una fuente de propósito general llamada VSRC. Una
vez localizada para seleccionarla picaremos en Place o bien haremos doble “click” sobre su
nombre. Con ello, el símbolo de VSRC aparecerá ligado al ratón de forma que podremos
emplazarla en cualquier lugar de la hoja en blanco. Una vez emplazada, el símbolo seguirá
unido al ratón para permitir colocar tantos elementos idénticos como se desee. Para finalizar el
proceso pulsaremos ESC.

Repetiremos el proceso anterior para colocar en el esquemático el resistor (R en la librería) y
el condensador (C). Trataremos de colorarlos en la misma situación que se muestra en la Fig.
1, pero ligeramente separados (no conectados). Para ello, una vez seleccionados (picando sobre
el elemento hasta que se ilumine en rojo o seleccionando un área que intersecte al símbolo o
conjunto de símbolos), podemos moverlos simplemente volviendo a picar sobre el elemento y
arrastrando el ratón mientras mantenemos el botón izquierdo pulsado. Además es posible rotar
o “especular” cualquier elemento o conjunto de elementos seleccionados mediante los menús
Edit->Rotate o Edit->Flip, respectivamente. Resulta cómodo antes de emplazar cada ele-
mento (esto es, mientras estén unidos al ratón) modificar su posición pulsado Ctrl+R o Ctrl+F.

Una vez que los tres elementos estén en la posición adecuada procederemos a su conexion-
ado. Para ello habilitaremos el menú Draw->Wire (equivalentemente Ctrl+W) y a continu-
ación marcaremos el punto inicial y final del cable. Continuaremos hasta completar las tres
conexiones y pulsaremos ESC para abandonar el modo de cableado. Tanto los cables como los
elementos se pueden eliminar seleccionándolos y pulsando la tecla Supr (DEL) o mediante
Edit->Delete.

Además de los tres elementos y su conexionado hay que proporcionar información de cual
será el nudo de referencia, a partir del cual se medirán todas las tensiones del circuito. Esta
información debe incluirse obligatoriamente en cualquier esquemático. Para ello se utiliza un
símbolo especial que representa a la tierra (0V) del circuito llamado GND_EARTH. Seleccio-
naremos dicho símbolo de la librería y lo coloraremos intersectando el cable inferior. En real-
idad la misión de este símbolo es asociar a dicho nudo la “etiqueta” (“label”) 0 (cero). Esta
etiqueta es una palabra reservada del simulador que se utiliza para designar al nudo de referen-
cia. El mismo resultado se obtiene asociando directamente dicha etiqueta al nudo, para lo cual
se hace doble click sobre el nudo en cuestión y se introduce la etiqueta en la ventana que se
muestra. Siempre es posible y conveniente asociar etiquetas a otros nudos con cualquier cadena
alfanumérica distinta de “0” con el fin de identificarlos claramente en los resultados de la sim-
ulación.
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Una vez añadido el símbolo de tierra, el esquemático debe ser similar al de la Fig.2. A los
nudos de entrada y salida del filtro se les ha etiquetado “in” y “out”, respectivamente.

El siguiente paso consiste en asociar valores a los elementos. Para ello, picando dos veces
sobre cada símbolo se nos muestra una ventana en la cual hemos de introducir cierta infor-
mación. Para modificar o añadir información en cierto campo haremos doble click sobre éste
y tras introducir el texto correspondiente pulsaremos ENTER.

En nuestro ejemplo, para la fuente de tensión introduciremos 1 en el campo DC =, lo cual
equivale a asociar un valor de 1V en DC. A continuación introduciremos 1 0 en el campo AC
=, con lo que indicamos que para un “análisis en AC” la magnitud de la fuente es 1V y su fase
0 grados; y finalmente introduciremos pulse (-1 1 0 1n 1n 10u 20u) en el campo TRAN = para
especificar que en un “análisis transitorio” la fuente proporcionará un tren de pulsos de valor
bajo = -1V, valor alto = 1V, retraso = 0s, tiempo de subida = 1ns, tiempo de bajada = 1ns,
tiempo en alto = 10µs y periodo = 20µs.

Operando del mismo modo asignaremos los valores de resistencia y capacidad, mediante el
campo VALUE = de su ventana de propiedades, aunque en este caso no deben ser modificados
pues los valores que tienen por defecto: R = 1k (1000Ω) y C = 1n (1e-9F), coinciden con los
del ejemplo. Las abreviaturas típicas son reconocidas: t = “tera”, g = “giga”, meg = “mega”, k
= “kilo”, m = “mili”, u = “micro”, n = “nano”, f = “femto”.

2.2 Especificación del análisis

Una vez capturado el esquemático, procederemos a especificar el/los análisis que se
requieren del simulador, mediante Anaysis->Setup... Con este comando se despliega la ven-
tana de análisis que se muestra en la Fig. 3 y que permite activar o desactivar cada tipo de análi-
sis y especificarlo convenientemente haciendo click sobre el nombre del análisis.

Existen tres tipos básicos de análisis en PSpice: Barrido en DC (“DC Sweep”), barrido en AC
(“AC Sweep”) y transitorio (“Transient”). Estos, junto al “Bias Point Detail” que proporciona
información sobre el punto de operación de un circuito, son los tipos de análisis más usados.
Pueden utilizarse aisladamente o en combinación con otro tipos de análisis como “Paramet-
ric...”, “Monte Carlo/Worst Case ...”, “Temperature ...”, etc. En este documento nos limitare-

Fig. 2
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mos a dar ejemplos de uso de estos análisis dejando la descripción detallada de los mismo para
el Manual de Usuario de la herramienta.

En la ventana de la Fig. 3, activaremos (“Enabled”) el análisis “AC Sweep”. A continuación
picaremos sobre “AC Sweep” y completaremos la ventana resultante como se indica en la Fig.
4(a). Esto equivale a realizar un barrido en frecuencias de la fuente de AC (o aquella que tiene
activado el campo AC =, en este caso la única que existe en el circuito; sólo una fuente por
esquemático puede tener asignada esta condición) en escala logarítmica con una densidad de
20 puntos por década, partiendo de 1Hz y hasta 1GHz. El resultado de este análisis será la vari-
ación con la frecuencia del modulo y la fase de la tensión de salida (o cualquier otra en el cir-
cuito). Como antes hemos asignado modulo = 1V y fase = 0 grados a la entrada, la señal de
salida representará a la función de transferencia entrada-salida, de forma que podemos obtener
así el módulo y la fase de la función de transferencia; esto es, el diagrama de Bode del circuito.

Por otro lado, activaremos el análisis transitorio e incluiremos los parámetros que se indican
en la Fig.4(b). Con ello queremos realizar un análisis de la evolución temporal durante los 20
primeros µs, tomando muestras cada 1ns. Durante este análisis se tendrá en cuenta el campo
TRAN = especificado en la ventana de propiedades de la fuente de tensión; esto es, el resultado
del análisis mostrará la respuesta del circuito a un tren de pulsos.

Fig. 3

Fig. 4(a)
Fig. 4(b)
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2.3 Simulación y visualización de los resultados

Una vez salvado el esquemático (File->Save) en el disco de usuario (nunca en el disco local),
ya estamos en condiciones de realizar la simulación. Previamente, en el menú Analysis, picare-
mos sobre Probe Setup... y activaremos la opción “Automatically run Probe after simulation”.
A continuación activaremos Analysis->Simulate o pulsaremos F11 para arrancar el simula-
dor. En respuesta, si no hay errores, aparecerá la ventana del simulador PSpice A/D, indicando
que los análisis solicitados están en curso.

Cuando finalice, arrancará automáticamente la utilidad Probe que permite visualizar los
resultados de la simulación. En primer lugar se nos preguntará qué análisis de entre los realiza-
dos queremos visualizar. Haremos click en AC. El resultado será una gráfica donde la frecuen-
cia (en escala logarítmica) se representa en el eje X. Activando Trace->Add (o Insert),
aparecerá una ventana que incluye a la izquierda todas las variables que podemos representar
en el eje Y de la gráfica. Además es posible realizar operaciones matemáticas con estas vari-
ables utilizando las expresiones que aparecen a la derecha. Por ejemplo, representemos el
módulo de la tensión de salida en dB: para ello, primero picaremos en DB( ) entre las funciones
de la derecha y luego en V(out) entre las variables de la izquierda (Fig.5). Cuando aceptemos
en OK, la curva solicitada se visualizará en la gráfica. Con ello hemos representado el módulo
de la función de transferencia en decibelios.

Para obtener el diagrama de Bode completo, representaremos en la misma gráfica, la fase de
la función de transferencia. Comenzaremos añadiendo otros ejes (los valores de la fase y el
módulo pueden ser bastante diferentes por lo que ambos en la misma gráfica pueden dar lugar
a problemas de escala) con Plot->Add Plot. La nueva gráfica es automáticamente seleccionada
como lo indica la palabra SEL>> cerca de su origen de coordenadas. Podemos seleccionar una
u otra simplemente picando con el ratón sobre cada curva. Seleccionar una gráfica implica que
las curvas que añadamos van a representarse en dicha gráfica. Seleccionaremos pues la gráfica
nueva y añadiremos en ella P(V(out)); esto es, la fase de la tensión de salida.

Fig. 5



Primer Ejemplo: Circuito RC

Tecnología de dispositivos y componentes electrónicos y fótonicos Ingeniero en Electrónica- Primer curso
 Dpto. Electrónica y Electromagnetismo, ESI, Universidad de Sevila

Página 6 de 10

Para medir datos sobre las curvas están disponibles sendos cursores que activaremos con
Tools->Cursors->Display (ó Ctrl+Shift+C), el primero de los cursores se controla con el
botón izquierdo del ratón y el segundo con el derecho. Se pueden cambiar de curva (ya sean
estas de la misma o de distintas gráficas) simplemente picando con el botón correspondiente
sobre el símbolo que aparece a la izquierda del nombre de la cantidad representada, bajo el eje
X de cada gráfica (Fig. 6). La abscisa y la ordenada de cada cursor, así como sus diferencias
respectivas aparecerán en un recuadro. Utilizaremos los cursores para medir el ancho de banda
de 3dB del filtro; esto es, la posición del polo, .

Los resultados del análisis transitorio se activan mediante Plot->Transient, lo cual nos pro-
porcionará una gráfica vacía con escala temporal en el eje X. En este y en cualquier otro tipo
de análisis existe una forma muy cómoda de representar variables (que no requieran un cálculo
previo; es decir, directamente tensiones en nudos o intensidades en los terminales de un dispos-
itivo). Para ello se ha de volver a la representación esquemático y añadir “sondas” de tensión
o intensidad en los puntos oportunos. Estas sondas se encuentran bajo el menú Markers de la
CE, aunque también pueden accederse mediante la barra de herramientas. Una vez en la CE, si
se añade por ejemplo una sonda de tensión al nudo de salida (para lo cual se ha de hacer coin-
cidir la punta de la sonda con el nudo en cuestión) y se pulsa ESC (para interrumpir la inclusión
de sondas), esta tensión se representa automáticamente en la gráfica activada de la herramienta
de visualización.

En la Fig. 7 se muestra el resultado y el uso de los cursores para medir el tiempo de subida
de la tensión de salida en respuesta al pulso en la entrada, a partir del cual es posible determinar
la constante de tiempo, .

Fig. 6
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3. Segundo Ejemplo: Rectificador de media onda

3.1 Introducción del esquemático

Analizaremos ahora las características de un rectificador de media onda añadiendo al circuito
anterior un diodo. Utilizaremos para ello el símbolo D de la librería, que representa a un diodo
genérico, y lo conectaremos como se indica en la Fig.8. Nótese que el valor del condensador
ha cambiado a 100µF y el de la resistencia a 10kΩ.

Fig. 7

Fig. 8
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Una vez completado el esquemático hemos de proporcionar una línea de modelo para el
diodo. Ésta debe acompañar a todos los dispositivos semiconductores y en ella se le proporcio-
nan al simulador los parámetros del modelo del dispositivo implementado en el simulador. Esta
información se incluye en un fichero de texto con el formato genérico:

.model nombre_modelo tipo_modelo par1=val1 par2=val2 ...

Donde nombre_modelo puede ser cualquier cadena alfanumérica, el tipo expresa a que dis-
positivo corresponde el modelo, (d para diodo, nmos o pmos para MOSFET, npn o pnp para
BJTs, etc.) y a continuación se incluyen los parámetros del modelo. En nuestro caso crearemos
un fichero de texto con el modelo del diodo:

.model diodo d is=2.682n n=1.836 rs=.5664 eg=1.11 cjo=4p

+ m=.3333 vj=.5 fc=.5 isr=1.565n nr=2 bv=250

+ ibv=100u tt=11.54n

y lo salvaremos con la extensión “.lib”.

Para asociar este modelo al diodo en la CE picaremos una vez sobre el símbolo del diodo para
que se ilumine y activaremos Edit->Model. Acto seguido picaremos sobre “Change Model
Reference”, lo cual nos permitirá introducir el nombre del modelo asociado a este diodo y que
obviamente deberá coincidir con el nombre_modelo incluido en el fichero “.lib”.

Lo único que resta es comunicar al entorno donde se encuentra el fichero “.lib” ya que se trata
de una librería personal (creada por el usuario). Para ello activaremos el menú Analysis-
>Library and include files... que nos permite navegar (Browse...) por nuestro disco hasta
localizar el fichero en cuestión y luego añadirlo mediante Add Include (sin asterisco).

3.2 Especificación del análisis

Analizaremos la característica entrada/salida en DC y la respuesta temporal a una entrada
sinusoidal.

Para visualizar la característica en DC hemos de realizar un barrido en DC (DC Sweep) de la
fuente de tensión. En el setup de análisis, activaremos dicho barrido y lo configuraremos como
se indica en la Fig. 9.

Para analizar la respuesta temporal, asociaremos en primer lugar una señal sinusoidal a la

Fig. 9
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fuente de tensión. Para ello escribiremos sin(0 100 50) en el campo TRAN = ; esto es, una señal
sinusoidal de offset = 0V, amplitud = 100V y frecuencia = 50Hz. A continuación, activaremos
el analysis “Transient” en el Setup e incluiremos Final Time = 200m y Step Ceiling = 0.1m
(el valor de Print Step no afecta a los resultados gráficos). Una vez hecho esto podemos correr
la simulación.

3.3 Simulación y visualización de los resultados

Cuando finalice PSpice se autoejecutará Probe, si así lo tenemos indicado en Analysis->
Probe Setup. Seleccionaremos el análisis transitorio y en la CE añadiremos sendas sondas de
tensión a la entrada y a la salida. El resultado se muestra en la Fig. 11(a). En esta gráfica se
puede realizar un “zoom” para visualizar con mayor detalle ciertos aspectos como la tensión de
rizado del rectificador, por ejemplo.

Los resultados del barrido en DC se muestran en la Fig. 11(b). Nótese que ahora el eje X se
corresponde con valores de la tensión de entrada, con lo cual la representación de está tensión
V(in) da como resultado una recta de pendiente unidad y que pasa por el origen. En la curva
correspondiente a V(out) se aprecia claramente la tensión de encendido del diodo.

Fig. 11(a)

Fig. 11(b)
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